Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Phantom Silver not Working
#1
I have a look like dead Phantom Silver.  Any success to reactivate or repair them?

Best Regards,

Chris
Reply
#2
(09-Apr-2020, 13:04)cr_qc Wrote: I have a look like dead Phantom Silver.  Any success to reactivate or repair them?

Best Regards,

Chris
Best to contact Devialet customer support and ask them to help you...
Reply
#3
(10-Apr-2020, 06:52)Snoopy8 Wrote:
(09-Apr-2020, 13:04)cr_qc Wrote: I have a look like dead Phantom Silver.  Any success to reactivate or repair them?

Best Regards,

Chris
Best to contact Devialet customer support and ask them to help you...
Hello,



Thank you for reply. I did. They seem to say I cannot really open it. This is highly pressure closed... I feel a little bit disappointed. Such an expensive equipment and it is not fixable...
Reply
#4
Tried to force reinstalling the firmware? If you're on DOS2 it's pressing the button on the speaker five times if I'm not mistaken.
Living room: Kii Three with Control. Phantom I 105 dB for TV. Remote v2
Den: 2x Phantom I 105 dB. Dialog. Remote v2. 
Porch: On sunny days, 1st gen. Phantom Silver and a Dialog running DOS1. Remote v1. 
My Phantom Voyage
Reply
#5
(10-Apr-2020, 22:23)ragwo Wrote: Tried to force reinstalling the firmware? If you're on DOS2 it's pressing the button on the speaker five times if I'm not mistaken.

Hello, I tried that too... No sigh of life...

Best Regards,

CR
Reply
#6
Sill question but have you tried the fuse in the mains plug?
Synology DS215 NAS (2x WD RED 1Tb) > Virgin Superhub 3 > HP Pavilion X360 laptop > Phantom Reactor 600 > JRiver MC25 > JRemote > A&K AK70mkii DAP > Supra Cat8 Ethernet cable > Sony WH-1000XM4 > jar of cream v2
Reply
#7
(13-Apr-2020, 18:06)Silvertouran Wrote: Sill question but have you tried the fuse in the mains plug?
Hello, Thank you for reply.  Actually I am using a standard cable. There is no fuse. The connection is direct. Still have no reaction from the speaker.

Best Regards,

Chris
Reply
#8
Update! I have been able to open the Silver unit... Very easy after I saw a video from a guy in Asia... However bug disappointment... We bought unit on used market as defective... After opening it, we found this unit was a Show demo. In other word, completely empty! No PCB... Only speaker and frame. Now we have a nice set of speaker who never run! All functional!

If someone want some part... Ring me a bell.

If interested how to open the beast... take 10 mins... Ring me a bell...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)