Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Roon, Expert Pro, and a major issue with RAAT
#1
This one has me stumped... I recently took my system apart to cleanup, dust-out and do a bit of rearranging.  When I got it back together, all seemed well.  Roon was able to stream via Roon AIR without a problem.    But when I switched to RAAT (which previously had been working fine on a 10/100mpbs link), things went bad... extremely loud, distorted music.  After immediately stopping playback, I switched back to AIR and it played fine.  In looking closer, I noted that the Roon RAAT zone was no longer showing the ability to control volume whereas AIR was showing the volume control correctly.  Clicking on the speaker icon, Roon was showing fixed volume.  That wasn't right but might explain why the music got so loud (but not why it was highly distorted). 

     

So I went into Device Setup for my RAAT zone which showed that Volume Control was correctly set for Device Volume.  But clicking on Volume Limits showed everything zeroed out, including Device Limits.  Something was clearly wrong.

   

I was stumped but on a whim, I decided to swap the ethernet cable to my Expert Pro.  Once I did, everything went back to normal!  I then put the old cable back and sure enough the same problem reappeared.  WTF?   How can a bad cable allow AIR to work but not Roon RAAT?  Worse, why did Roon still see the Expert Pro yet not pick up the correct Volume Limits?

Has anyone seen anything like this?  I have posted a question on the Roon Support forum but without a reply as of yet.
Devialet 440 Pro (two 220s)- Oracle CD transport - Kuzma Stabi S/Stogi S turntable - Von Schweikert VR-35 speakers - JPS SC3 SCs - PI Audio power conditioning -
Triode Wire Labs ICs and PCs - Roon Labs music streaming
Durham, NC USA
Reply
#2
Haven't had any issues like that.

RAAT uses more bandwidth than AIR, more data including data back to Roon from the Devialet, and more error checking/correction. Maybe that was the issue.

Can you put the problem ethernet cable in another location, preferably where it will carry an AV signal including video so that a lot of data is being carried but Roon isn't involved? For example I can stream video straight to my TV using apps on the TV, and also via an Apple TV using apps on it. If you can make such a swap, does the cable work in that situation? If not then the cable isn't working properly in 2 separate situations, one of which doesn't involve Roon, so that would mean it's not a Roon or a Devialet problem and the problem would have to be a faulty cable since that's the only thing that would be common to both situations.
Roon Nucleus+, Devilalet Expert 140 Pro CI, Focal Sopra 2, PS Audio P12, WireWorld Starlight ethernet cables, Uptone Audio EtherREGEN, Kimber Select speaker cables, Shunyata Alpha NR and Delta EF power cables power cables, Grand Prix Audio Monaco rack, RealTRAPS acoustic treatment.

Brisbane, Qld, Australia
Reply
#3
(11-Feb-2020, 01:59)David A Wrote: Haven't had any issues like that.

RAAT uses more bandwidth than AIR, more data including data back to Roon from the Devialet, and more error checking/correction. Maybe that was the issue.

Can you put the problem ethernet cable in another location, preferably where it will carry an AV signal including video so that a lot of data is being carried but Roon isn't involved? For example I can stream video straight to my TV using apps on the TV, and also via an Apple TV using apps on it. If you can make such a swap, does the cable work in that situation? If not then the cable isn't working properly in 2 separate situations, one of which doesn't involve Roon, so that would mean it's not a Roon or a Devialet problem and the problem would have to be a faulty cable since that's the only thing that would be common to both situations.
 @David A - that's exactly what I've done, and the cable still seems to be working just fine.  My guess is that it still isn't loaded to the extent RAAT loads it.  

What scares/worries me is that Roon allowed me to stream music to my Expert Pro when there was clearly a problem resulting in a very load, distorted sound.  Until this, I would have thought that Roon would have simply dropped my Devialet RAAT zone if there were serious communication issues over the ethernet link.  I'm hoping to get further insight from Roon Support on this (time will tell).

Do you use both RAAT and AIR zones to your Expert Pro?   If so, and if your Expert Pro is off or sleeping and you start up a Roon app, does your RAAT zone show a volume value or does it have to wait until your Expert Pro awakens and you select the zone?   My "memory" would say that the RAAT zone always showed a volume value even when the zone was not being used.  Even when the Expert Pro was still sleeping or set on a different source.   But that is not what I'm seeing now.  But then, I've learned to not put much weight on what I think I remember.
Devialet 440 Pro (two 220s)- Oracle CD transport - Kuzma Stabi S/Stogi S turntable - Von Schweikert VR-35 speakers - JPS SC3 SCs - PI Audio power conditioning -
Triode Wire Labs ICs and PCs - Roon Labs music streaming
Durham, NC USA
Reply
#4
@mdconnelly,

If I remember correctly from one of the threads about the original RAAT problem, streaming music via RAAT uses about 10-11 MBps. Streaming UHD video from Netflix uses up to 25 MBps but streaming lower resolution video would use less and I'd expect 1080P to possibly use less than RAAT and high res music.

In order for Roon to not stream music when there's a problem Roon has to know there's a problem. If there's no information getting back to Roon then Roon isn't going to be aware of the problem so it will simply keep doing what it's supposed to do and keep streaming. I tried to find your post on the Roon boards but couldn't seem to find it. Can you post a link to your post there?

I have used both RAAT and AIR to my 140. I normally use RAAT and basically only ever use AIR if I'm experiencing a problem with RAAT. With RAAT, I don't see a volume setting displayed in the Roon app on my iPad until my 140 wakes up. Roon can wake the Devialet up if I tell it to play something while the 140 is off or asleep but I usually don't let it go to sleep, I turn it off when I'm finished playing music. My guess would be that the Devialet can wale up on a request from Roon, like a device can wake up from a signal on a trigger cable, but Roon doesn't know what the amp's volume setting is until the amp has finished booting because the startup volume and also the volume on input switch are both settings which are taken from the config file when the amp is booting. That probably means that Roon has no way of knowing what the volume setting is until the amp is actually ready to start receiving and processing the stream and Roon can't display a volume setting until it gets that data from the amp. I think the volume setting may be retained while the amp is sleeping because it is still on to some degree but I could be wrong on that.

I just checked your top screen capture of the zones display and noticed you were playing Viktoria Tolstoy. It seems we have something else in common besides Devialet, Roon, and RAAT :-) I've only started listening to her recently but I like what I've heard.
Roon Nucleus+, Devilalet Expert 140 Pro CI, Focal Sopra 2, PS Audio P12, WireWorld Starlight ethernet cables, Uptone Audio EtherREGEN, Kimber Select speaker cables, Shunyata Alpha NR and Delta EF power cables power cables, Grand Prix Audio Monaco rack, RealTRAPS acoustic treatment.

Brisbane, Qld, Australia
Reply
#5
Love Ms. Tolstoy’s latest album titled “Stations” which was just released a few days ago. Love her voice and music.

My post in Roon Support is here...

https://community.roonlabs.com/t/deviale...mdconnelly

Not much more than my post above.
Devialet 440 Pro (two 220s)- Oracle CD transport - Kuzma Stabi S/Stogi S turntable - Von Schweikert VR-35 speakers - JPS SC3 SCs - PI Audio power conditioning -
Triode Wire Labs ICs and PCs - Roon Labs music streaming
Durham, NC USA
Reply
#6
(11-Feb-2020, 03:06)mdconnelly Wrote: ...
Do you use both RAAT and AIR zones to your Expert Pro?   If so, and if your Expert Pro is off or sleeping and you start up a Roon app, does your RAAT zone show a volume value or does it have to wait until your Expert Pro awakens and you select the zone?   My "memory" would say that the RAAT zone always showed a volume value even when the zone was not being used.  Even when the Expert Pro was still sleeping or set on a different source.   But that is not what I'm seeing now.  But then, I've learned to not put much weight on what I think I remember.

I just tried this on my system to see how it behaves.  I use RAAT and normally wake up the Devialet from Roon, simply by asking to play something.  There is initially no number associated with the volume icon; if I open the volume dialog immediately, I can see that it says "Fixed volume" initially, which changes to the volume slider (with the configured default volume) when the amp fully wakes up.

That said, I do have a vague memory similar to yours that the volume display used to work a little differently at start-up, and that the volume icon always had a numerical value.
Roon (Mac Mini), Wilson Benesch Full Circle, Expert 1000 Pro CI, Kaiser Chiara
Warwickshire, UK
Reply
#7
@mdconnelly

I don't know why I couldn't find your post on the Roon forums when I looked previously but thanks for the link, and I can also now locate it myself when I look.

Anyway, just saw your responses from Roon. Not overly helpful. It's a bit hard to see how you could have failed to power cycle your 440 twice after a firmware review update when it's exactly 12 months to the day today (already 12 February here in Australia) since the last firmware update. I know my 140 has been power cycled multiple times in the last month simply due to being disconnected from power during electrical storms during our storm (and fire) season. It's hard to see anyone's amp not being power cycled several times for one reason or another over a 12 month period unless Roon, and you, know something we don't. Is there a new update coming that you've been secretly beta testing? OK, that was a joke and we all know we can ignore that possibility. So Roon are no help on this one.

I can't think of anything other than the cable but that doesn't seem to be a plausible answer in some ways. Since you have things working again with a different cable, all I can suggest is letting it continue to run and see if the problem recurs again at some stage. Not the answer you probably want to hear but sometimes that's all you can do and I think this looks like one of those times.

I hadn't heard Viktoria Tolstoy's "Stations" but I played it on Tidal last night and ended up purchasing the album as a 96/24 download. Thanks for the recommendation on that album.
Roon Nucleus+, Devilalet Expert 140 Pro CI, Focal Sopra 2, PS Audio P12, WireWorld Starlight ethernet cables, Uptone Audio EtherREGEN, Kimber Select speaker cables, Shunyata Alpha NR and Delta EF power cables power cables, Grand Prix Audio Monaco rack, RealTRAPS acoustic treatment.

Brisbane, Qld, Australia
Reply
#8
I did reload the OS and firmware, but that wasn't until after the problem occurred. But when I did dismantle all the cabling to clean the system prior to the problem, I do remember inadvertently popping out one of the SD cards and not realizing it until after it rebooted in factory mode. So perhaps that may have also caused the problem. I had never heard the loud right channel noise before so it has now made me quite wary. I will make sure I do see the proper volume setting before pressing play - particularly if/when we ever get a new update to load. (Hah!)

I still think the Devialet implementation of RAAT is just a bit flakey but it's working fine for me now, even using the old ethernet cable that I mistakenly thought was the problem. No, it's still not working perfectly at gigabit speed for me. Awhile back I did try it again after I had AT&T change out my router for a different issue. The new router is an Arris BGW210. At first, I thought that problem was fixed, but about 3 minutes into a 192kHz, 24Bit song, I started getting dropouts again. But it is sounding glorious at 10/100 so I'm content with it.

Thanks for jumping in!
Devialet 440 Pro (two 220s)- Oracle CD transport - Kuzma Stabi S/Stogi S turntable - Von Schweikert VR-35 speakers - JPS SC3 SCs - PI Audio power conditioning -
Triode Wire Labs ICs and PCs - Roon Labs music streaming
Durham, NC USA
Reply
#9
Glad to hear you got it fixed. Still a bit scary, though.
Roon (Mac Mini), Wilson Benesch Full Circle, Expert 1000 Pro CI, Kaiser Chiara
Warwickshire, UK
Reply
#10
(11-Feb-2020, 17:45)thumb5 Wrote:
(11-Feb-2020, 03:06)mdconnelly Wrote: ...
Do you use both RAAT and AIR zones to your Expert Pro?   If so, and if your Expert Pro is off or sleeping and you start up a Roon app, does your RAAT zone show a volume value or does it have to wait until your Expert Pro awakens and you select the zone?   My "memory" would say that the RAAT zone always showed a volume value even when the zone was not being used.  Even when the Expert Pro was still sleeping or set on a different source.   But that is not what I'm seeing now.  But then, I've learned to not put much weight on what I think I remember.

I just tried this on my system to see how it behaves.  I use RAAT and normally wake up the Devialet from Roon, simply by asking to play something.  There is initially no number associated with the volume icon; if I open the volume dialog immediately, I can see that it says "Fixed volume" initially, which changes to the volume slider (with the configured default volume) when the amp fully wakes up.

That said, I do have a vague memory similar to yours that the volume display used to work a little differently at start-up, and that the volume icon always had a numerical value.

It certainly does work differently and quite consistently with Devialet AIR, but hey, it's working now I'm good.     Thanks for the info!   

What I find a bit strange is that if I wake up my Expert Pro via the Devialet remote and then switch to the Roon Ready input, the remote will correctly show my default volume (-40db) before I hit play.   But if I start my Devialet from my iphone or ipad Roon app, my Expert Pro will show no volume setting for the Roon RAAT zone until I start playing it.   A 3rd scenario occurs when I startup the Expert Pro via another input (say my TV line-in), the Roon RAAT zone will strangely show -42db.  But once I start playing to that zone, it correctly switches to my default volume of -40db.   

Perhaps there's logic to the implementation, but damn if I see it.   Still, it's working well and sounds great so I'm good.
Devialet 440 Pro (two 220s)- Oracle CD transport - Kuzma Stabi S/Stogi S turntable - Von Schweikert VR-35 speakers - JPS SC3 SCs - PI Audio power conditioning -
Triode Wire Labs ICs and PCs - Roon Labs music streaming
Durham, NC USA
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)